Osclass Community Market Osclass Community Market Osclass Community Market

Digital Download Plugin Question

Started by RiaanN, January 27, 2020, 05:12:53 pm

Previous topic - Next topic

RiaanN

Good Day

I am very new to Osclass. I installed version 3.9.0 today just to get the feel for the backend, and ended up installing a plugin - Digital Goods V1.1.0

If I add a listing while logged in as Admin, the file is then shown on the front-end, but if I want to remove the listing I can't because of the file. For some reason nothing happens when you click on delete file.

Socond problem

If I add a new listing using the "Publish your add for free", the zip file does not appear in the front-end

Am I trying to use a plugin that is maybe to old for the installed Osclass version ?


rusnam

January 28, 2020, 11:25:34 am #1 Last Edit: January 28, 2020, 11:54:55 am by rusnam
Did you selected the category in digitalgood setting?

Delete issue, the plugin does not remove the data form database
DGmodel.php line 115

Modify this line From this
$this->dao->query("DELETE FROM ocer_t_item_dg_files WHERE fk_i_item_id = $itemId", $this->getTable_DG(), $dg['pk_i_id']);
To this
$this->dao->query("DELETE FROM %s WHERE fk_i_item_id = $itemId", $this->getTable_DG());
But still not working anything i have missed?

WEBmods

@rusnam

$this->dao->query(sprintf("DELETE FROM %s WHERE fk_i_item_id = $itemId", $this->getTable_DG()));
Like my work? Buy me a coffee or request a quote for custom development.

RiaanN

Thank you very much. The listing can now be deleted without any problems.

Regarding the second issue:
From the Frontend I can upload a file but only a very small file (Less than 1MB). It there a restriction on the upload size ?

rusnam

Thank you @WEBmods ill add this plugin in to market.

rusnam


RiaanN

Thank you very much - I really appreciate your help

RiaanN

Hi Rusnam

After installing the new version of the plugin, I am running into weird issues.

1. Error - Some of the files were not uploaded because they have incorrect extension

- I double checked this - I am using WinRAR to either make a .zip or .rar file
- I made sure that it is specified in the list of allowed files
- I added pdf to the list but it gives the same error

Reverting back to the v1.1.0 version fixed the file type problem, but still leaves me with the file size problem.